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1 What is the use of GizmoMarks ?

In its new version (2.X.X) , GizmoMarks handle collections of secured electronic notebooks. The data of
that notebooks are classified in topics and each topic consists of a unlimited numberof categories :

• Categories of notes (typed or pasted text).

• Categories of links to applications or documents located on your computer or the network..

• Categories of link to web sites or electronic mails.

• Categories of passwords to memorize.

• All data of a notebook can be saved and crypted by a 128 bits key.

• The program GizmoMarks exist also for the Windows and Linux platforms.

The generated notebook (files with the extension .bef) created on a Mac can be used on the Windows
or Linux platform and the reverse is true. So, you may use this program in an heterogeneous network or
through the Cloud.

1.1 New in version 1.9.0

• Use of a floating stocker: A ’sticker’ in the likeness of GizmoMarks icon is continuously displayed
on the screen (see figure [8]. It can be placed anywhere on the screen. By clicking this ’sticker’ can
bring back the window GizmoMarks when hidden.

• Appearance of the sentence Your data are locked in the context menus of the list of topics and
notes.

• Added new keyboard shortcuts: Cmd+: to access About... and Cmd+; for access to updates.

• Fixed minor bugs:

– The password field was not locked.

– Suppression of research in the list of topics at a keystroke in a field when data are locked.

1.2 New in version 1.9.2

• During an GizmoMarks session, the passwords of encrypted notebooks that have been opened are
stored in memory, so we can reopen them without providing the password. This simplifies the naviga-
tion among your notebooks. Of course, if you leave your computer, you can delete these passwords in
memory (see Figure [11]) so that an unidentified user is obliged to know the passwords of your secure
notebooks.

1.3 New in version 2.0.0

• Notebooks can now be grouped into collections (see figure [2] et [3.5]).

• The creation of common paths for the use of notebooks on different machines [3.5.7].

2 GizmoMarks functionnalities.

If the interface is not in english, choose the language with the Preferences:

Menu GizmoMarks→Preferences [3.6.1].
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Figure 2: Overview of the application window. Can be seen to the left of the list notebooks (M) for a
collection of notebooks given (here Mots/Words) and the list of topics (B) related to a notepad (Mots).
The frequent application drawer (right) is deployed and floating sticker is visible in the upper right.

2.1 Interface

The tools of GizmoMarks are avaiable in the main window (see figure [2]), and the menus [??]. The toolbar
A shows the main tools of the application. You can also reach these functions by the main menus. On the
main window we have:

• A The toolbar.

• B The list of the topics.

• C The title of the current topic.

• D The category notes associated to the current topic.

• E The category document associated to the current topic.

• F The category addresses web (Url) or e-mail.

• G The category password.

• H A scroll bar, when the number of notes, Url or passwords is big.

• I The title of the file containing the data and the number of topics.

• J The dates of creation and modification of the topic.

• K A disclosure triangle for the applications drawer.

• L The drawer of the frequently used applications.

• M List of the notebooks collection (New).

• N Floating sticker. This sticker can bring the window of GizmoMarks in front.
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2.2 Tools

Figure 3: The set of tools

In the toolbar, one has 15 elements that are also accessible by the main menu:

• 1 Creation of a new notebooks.

• 2 Opening of an existing notebook.

• 3 Addition of a topic to the notebook.

• 4 Opening of an recent notebook.

• 5 Save the current notebook.

• 6 Save the current notebook current under another name.

• 7 Lock/Unlock the bloc-note.

• 8 Search of a character chain in the current notebook.

• 9 Change the bloc-note status from private(crypted) to public (uncrypted).

• 10 Acces to program’s documentation (this file).

• 11 Access to program’s Preferences.

• 12 Check for updates.

• 13 Print the selected topics.

As regards the main window, it has 6 tools to manage the categories:
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• a Add a category.

• b Suppress a category.

• c Insert a link to an application or a document. If you wish to insert a link to a folder, press the Shift
key.

• d Launch the application or reach the document.

• e Reach an Url address or to send a message to an address e-mail.

• f Copy the category.

2.3 The Menus

GizmoMarks has 5 menus (to see figure [4]):

• The menu GizmoMarks.

• The menu File.

• The menu Edition.

• The menu Tools.

• The menu Help.

Most these menus have their equivalent in the Toolbar, except for the menus GizmoMarks→About,
File→Merge file (the same function can be obtained by a drag and drop from a notebook file (.bef)
on the main window), and the menus Tools→Change password, Tools→Manage common paths,
Tools→Search for notebooks and Tools→Reset scrolling.

Here is the list of the menus:

• Gizmomarks→About GizmoMarks... (Cmd+:).

• Gizmomarks→Check for updates... Same as tool 12 (see figure [3]). (Cmd+;).

• Gizmomarks→Preferences... (Cmd+,) by witch you can in particular change the interface lan-
guage (english or french). Same as tool 11 (see figure [3]).

• File→New notebook (Shift+Cmd+N). Same as tool 1 (see figure [3]).

• File→New topic (Cmd+N). Identical to the tool 3 (see figure [3]).

• File→Open (Cmd+O). Identical to the tool 2 (see figure [3]).

• File→Open a recent notebook. Identical to the tool 4 (see figure [3]).

• File→Merge file... (Cmd+M) (The same function can be obtained by a drag and drop from a
notebook file (.bef) on the main window)

• File→Save (Cmd+S). Identical to the tool 5 (see figure [3]).

• File→Save as (Shift+Cmd+S). Identical to the tool 6 (see figure [3]).

• File→Page setup (Shift+Cmd+P). Paper orientation and printer parameters.

• File→Print selected topics (Cmd+P). Identical to the tool 13 (see figure [3]).

• Edition→Cut (Cmd+X). Accessible by the contextual menu (Ctrl+Click mouse or Click right
Mouse) in the categories.
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Figure 4: The menus

• Edition→Copy (Cmd+C). Accessible by the contextual menu (Ctrl+Click mouse or Click right
Mouse) in the categories.

• Edition→Paste (Cmd+V). Accessible by the contextual menu (Ctrl+Click mouse or Click right
Mouse) in the categories.

• Edition→Select All (Cmd+A). Select a whole category.

• Edition→Find (Cmd+F). Identical to the tool 8 (see figure [3]).

• Tools →Lock / Unlock (Cmd+L). Identical to the tool 7 (see figure [3]).

• Tools →Make Public/Private (Cmd+U). Identical to the tool 9 (see figure [3]).

• Tools →Change password (Shift+Cmd+M).

• Outils→Manage common paths (Cmd+G).

8



• Outils→Search for notebooks (Cmd+G). Allows you to search notebooks in a directory, to select
and insert them in the current collection of notebooks.

• Tools →Reset scrolling (Cmd+R). Reset the categories position changed by the scrolling bar H
(see figure [2]).

• Help →Help of GizmoMarks... (F1). Permits to read this file. Identical to the tool 10 (see figure
[3]).
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2.4 The contextual Menus

One has 2 contextual menus (see figure [5], [6],[7]): for the list of notebooks, for the list of topics and for the
categories

Figure 5: The contextuel menu of the list of notebooks. Obtained by a right-click (or CTRL + click)
in the list of notebooks (M see figure [2]). This menu allow you to:

• rename the notebook collection.

• remove the notebook collection (but keeping the notebook on the disk).

• create a new notebook collection.

• rentame the current notebook.

• remove the current notebook from the current collection(but keeping the notebook on the disk).

• to slect an existing collection.

• to erase the notebooks passwords keeped temporary during a session.

Figure 6: The contextuel menu of the list of topics: You can copy the topic of a notebook to paste
it in another notebook if this notebook is unlocked). Moreover if you sleet topics in this list, you can print
your choice of category. This menu allow you to do:

• select the topics to print.

• delete a topic.

• cut/copy a topic.

• to paste a cutted or copied topic in another notebook (when this notebook is unlocked).

• to choose the main window color.

• to choose the text color of the main window.
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Figure 7: The contextual menu of a category allows th traditional operations cut/copy/paste, to chane
the text size and the background color of a category. You can also adjust the height of the category Note by
100 pixels increment . This menu allow you to do:

• Cut/Copy/Paste the text in a category.

• Chose the text size in a category.

• Choose the background color of a category.

• Choose the vertical size of a Note.

3 Use of GizmoMarks .

3.1 Start of version 2.XX de GizmoMarks .

With version 2.XX, notebooks can be grouped into collections. A collection is a set of notebooks grouped
by the user. Startup GizmoMarks is then a little different. There are two cases:

• Cas a: The user has never used GizmoMarks or the preferences file [1] has been deleted or is
unreadable. In this case the user must first create a notebook that GizmoMarks place in a collection
that you must rename.

• Cas b: The user has already used an earlier version of GizmoMarks . In this case, GizmoMarks
will start with the last used notebook and place it in a collection that you will need to rename.

The easiest way to understand the difference is to watch short films posted on the web:

Video: First start of GizmoMarks

3.2 Adding a notebook to the collection.

After the first launch, one has created a first collection with a first notebook. One is ready to create a second
notebook:

• The tool Save (1) is inhibited since no modification has been done.

• The tool Add a Topic (2).

• The tool Add a notebook (3).

• The tool Create a notebook (4).

• The two imodification indicators (5) are virgin.

• The collection name is here Funny words.

• The notebook name is here Words.
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Figure 8: Opening GizmoMarks . You can see the floating ’sticker’ that can be placed anywhere on the
screen. Clicking this sticker can bring back the main window of GizmoMarks when hidden.

• The name of the selected topic is here anthropisation.

• The creation and modification dates corresponds to the creation and modification of the selected
topic.

• The topic’s category (1 note, 1 documentation, 1 URL adress, 1 mot password) are the default cate-
gories.

To create a notepad just click on the button (4) from figure [8] (Tool (1) of figure [3]) or the
Menu File→New notebook (Shift+Cmd+N). This action opens a dialog to define the name of the new
notebook and set its location to its backup.

Another way is to add to the collection an existing notebook by clicking on button (3) of figure [8]
(Tool (2) of figure [3]). We then open a dialog to open an existing notebook.

3.3 Adding a topic to the notebook.

To add a topic you click on button (2) of figure [8] (tool (3) od figure [3]).
In the wording of the topic, replace New Topic by Topic #1. Indicators of changes are no longer

virgins. The wording being changed, type ¡Enter¿ or move the mouse outside of the wording field. The topic
appears in the list. The left indicator of change becomes virgin because the topic is in the computer list,
but the right indicator of change is still touched, because the change is not saved on disk.

The tools Add a topic (2) and Save (1) are activated, and the modification date is changed. In the
list, Topic #1 is selected.

Let us now changing topics.

3.3.1 The category Note.

It is the D category of the figure [2]. In this category one can type any text or with the help of the
contextual menu (figure [7]) to modify it by /Cut/Copy/Paste. Let’s recall that the contextual menu gets
itself, either by a Control+Click of the mouse (mouse with 1 button), or by a left click (mouse with 2
buttons).

12



Figure 9: Adding a notebook: replace Untitled by th name of th new notebook, and select the place
where it will be saved.

3.3.2 The category Documentation/Application.

It is the category (E) of the figure [2]. To use this category, one clicks on the tool Insert a link to
an application or a document (c) of the figure [3]. The program allows you then to navigate through
your computer or the network to fix the path of access to a document or an application. While clicking on
the tool Launch the application or reach the document (c) of figure [3]., you can reach the selected
element.

3.3.3 The category URL.

It is the category (F) of the figure [2]. To use it, it is sufficient to write the address URL or the electronic
address that one wants to join. This can be made also using the contextual menu to Paste in this category.

3.3.4 The category Password.

It is the category (G) of the figure [2]. To use it, it is sufficient to write the password to memorize. This
can be made also using the contextual menu Cut/Copy/Paste in this category. The password is concealed
as for oneself leaves this category. To copy the password one is able either to use the contextual menu to
Copy, either the tool to Copy the category, (f) of the figure [3].

3.3.5 Crypting a notebook.

If you want to protect your passwords, or of other data, you can choose to encode the file. For this
purpose one uses the tool 9 of the figure [3], to Change the statute of the current notebook: public
or private (encoded). The program asks you then to fix a password and to confirm it. When you will
record your notebook, it will be encoded. You will have the keep this password in your memory to read your
notebook.

3.3.6 The password dialog.

At a notebook opening, if it is crypted, the passwor dialog appears (see figure [10]).

• Button Cancel (see Figure 10): abort opening.
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• Button Show password (see Figure 10): allows to see the characters you type.

• Button Other file (see Figure 10): to select another file.

• Button Red: stop GizmoMarks .

Figure 10: The password dialog at opening of a crypted file.

3.4 Add/Suppress a category.

The number of categories is arbitrary.
With the tool [+] (a) and the tool [−] (b) (see figure [3]) you can add or can suppress a category of

any type (Note, Documentation, Url or Password).

3.5 Use of notebook collections.

When GizmoMarks start, the last used collection is open. The selected notebook is or the last used in
the collection, or the notebook specified in the Preferences (See Notebooks organization [3.6.4]).

The contextual menu of the collections list (see figure [2]) allows to manage the collections.
With this contextual menu you can:

• Rename the collection of notebooks.

• Erase the collection of notebooks (but don’t erase notebooks).

• Create a new collection of notebooks.

• Rename the current notebook.

• Remove the current notebook from the collection (but don’t erase it).

• Select another collection of notebooks.

• Erase the password of the crypted notebooks keeped during a session: when a crypted notebook is
open during a session of GizmoMarks , you have to give it’s password. This password is keeped by
the program as long as you don’t leave the collection or the program. In case you leave your computer,
you can make you session secure by erasing the passwords using this contextual menu.

3.5.1 Opening a notebook.

By clicking on the notebook name in the collection list, you open the notebook. If the notebook is
crypted, you need the password to read it. When the notebook is open it’s locked to avoid any inadvertent .
You can unlock the notebook using the tool (7) of figure [3] or menu Tools→Lock/Unlock (Cmd+L) of
figure [4].
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3.5.2 The tool Find.

This tool (8) of the figure [3] or of the menu Edition→Find (Cmd+F) permits search in the current
notebook of a chain of any characters. One can spread research to all categories or can limit it to some
categories.

Other research tip: When the list of topics has the focus, typing a letter or number will scroll the list
until the first topic having this letter as first character.

3.5.3 The menu change password.

If you opened an crypted notebook, you can change its password while using this menu.

3.5.4 Creation of a new notebook.

It is the tool (1) of the figure [3] or the menu New notebook of the figure [4]. While creating a new
notebook, one meets in the conditions described to the paragraph (3.2).

3.5.5 The menu File→Merge with notebook....

This menu, (File→Merge with notebook... (Cmd+M)) is activated if the current notebook is unlocked.
This give you th possibility to merle too notebooks. Note that can do this by dragging and dropping a
notebook file (.bef) on the main window.

The notebook, result of this merge is automatically saved.

Important notice This notebook keep it’s statute (Public/Private) and keep it’s original password.

3.5.6 The File→Open a recent notebook.

This menu (see figure [4]) add a recent notebook to the current collection. You have access to this choice

Figure 11: Dialog Recents files and it’s associated popup menu.

using tool (4) of figure [3], which gives you the choice of the recently open or saved notebooks in all existing
collections (voir figure [11]).

3.5.7 The Tools→Manage common paths

.
Suppose that your topics have categories (E) (see figure [2]) Documentation/Applications making

reference to files existing on various stations using GizmoMarks . A priori access to these courses are
different depending on the stations, if only because some stations use Mac OS and other Windows or Linux.
Then you can define a CPAS (Common Path Accros Stations) or PCIP (Parcours Commun Inter Postes)
in order that your categories have access to the document or application whatever the station.
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The menu Tools→Manage common paths allows you to perform this operation (see figure [12]).

Figure 12: Common path dfinition (PCIP). Clicking on th + button, you may add a name to a common
path and clicking on the second column, you have access to a dialog to specify the folder choice.

Supposing that your category Documentation/Applications make reference to files synchronized
through the cloud, for example in a folder Dropbox (or Skydrive, etc...) or one of it’s sub-folder. It will
be enough to define the PCIP Dropbox on each station in order to make the categories Documenta-
tion/Applications functional.

3.5.8 The menu Outils→Search for notebooks.

Allows to search in a folder the notebooks files and to select the one you want to include in the current
collection.

3.5.9 Drag and drop.

By drag-and-drop on the main window of GizmoMarks you may add a notebook (extension .bef) in
the current collection. The choice between adding the notebook to the current collection or merging the
notebook with the current notebook is given by a dialog.

3.6 Using preferences.

You can reach the preference by the menu item from the GizmoMarks , or by the tool 11 from figure
[3] or typing the shortcut Cmd+,.

3.6.1 Langage choice.

With the Preferences you can choose the langage of the interface. The Automatic option set the
language to the system language (if it’s french or english). The popup menu allows to choose english or
french whatever is the system language.

3.6.2 Update.

You can also choose to check for updates at startup, knowing you can always check for updates using
the menu Help→Check for Updates (see figure [4]) or the tool 12 (see figure [3]).

3.6.3 Show the Applications drawer.

You may choose to show the Application drawer (see figure [16])when the application open.
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Figure 13: Dialog Select th notebooks. You select one or more notebooks to insert then in the current
collection.

Figure 14: Preferences dialog

3.6.4 Notebooks organisation.

You can also choose to organize your recent files (if you have), i-e to define the file loaded when the
application starts.

That window (figure [15]) shows the recent files list. The first column is a check box. When a box is
checked, the selected file will be loaded at the next application start. The second column gives the full path.
The directory name and the file name from the selected path are shown at the list top.

If you wish to suppress all priority, simply click the button No file at start: this will uncheck the files.
If no file is selected, the last opened notebook will be loaded at next start.
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Figure 15: Dialog Notebooks organisation. One may choose the starting notebook for each collection with
the pop-up menu

3.7 Applications drayer.

By clicking on the triangle (circled in red, on figure [16], it shows a window tray that can hold a series
of shortcuts useful to launch applications. The button + alloows to add an application. Right clicking on an
icon will immediately lauch the application. With a left-click or control-click on an icon of an application,
we can add / delete or rearrange the icons. The scroll bar on the left of the drawer window provides access
to a unlimited collection of shortcuts.

Figure 16: Applications drawer to launch frequently used applications.
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References

[1] The preferences file, User being your username:

• on Mac is named MacPrefsGizmoMarks.txt and is located in folder:

StartVolume:Utilisateurs:User:Bibliothque:Preferences:Gizmotique:

• on Windows is named WinPrefsGizmoMarks.txt and is located in folder:

X:Utilisateurs\User\AppData\Roaming\Gizmotique\
X tant le volume de dmarrage.

• on Linux is named LinPrefsGizmoMarks.txt and is located in folder:

home/User/Gizmotique/
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