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1 What is the use of GizmoTakePict ?

GizmoTakePict s a utility for making screenshots. The capture zone can be specified
as well as the post-processing. With post-treatment is possible:

• Either place the capture to the clipboard.

• Either automatically save the image to a predefined folder.

• Or save the image ’manually’ by specifying its name and where it is stored.

• Or add annotations to the image.

• You can then print and save the annotated image:

– The image file with annotations (format .jpg format if the original image has
no transparency., format .png if the original image has transparency).

– A metafile [1] to change the annotations (.qtpi).

GizmoTakePict allows also:

• Or annotate an image in format .jfif, .jpe, .jpeg, .jpg, .png, .bmp; .tif, .tiff, .gif, .jp2,
.pct, .psd.

• Or edit a metafile (extension .qtpi).

2 Installation (Windows).

To install GizmoTakePict , just run the installer SetupGizmoTakePict.exe. If the
program finds a previous installation of GizmoTakePict , it offers to remove it. It is
recommended to do so and restart a second time SetupGizmoPictTake.exe.

Note: In order for metafiles (extension .qpti) are loaded by a simple double click by
GizmoTakePict , at a first opening just use the context menu item Windows Open
With... and using the Browser button, select the default program:

C:\Program Files(x86)\GizmotiqueGizmoTakePict\GizmoPictTake.exe

Do not forget to check the Always use the selected program to open this type
of file.

For your information, GizmoTakePict uses a preferences file which is a text file:

C:\users\USERNAME\AppData\Roaming\Gizmotique\GizmoTakePict.txt

where USERNAME is your username.

3 Using GizmoTakePict

GizmoTakePict window at startup is shown in Figure [2].
Button # 1 allows you to access help (this file). Button # 2 allows you to set prefer-

ences (voir [4]) which is useful to define the post-processing.

1A metafile is a binary file (extension .qtpi) storing the image and annotations. It can be read by
GizmoTakePict for Windows or Mac OS.
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Figure 2: Opening the program. Welcome dialog

3.1 Button: Fix the frame.

Provides access to the screenshot. (see 5) .

3.2 Button: Annotate an image.

Allows you to load an image to annotate (see 6).

3.3 Button Change metafile.

Can load a metafile to change (see 7).

4 Preferences.

See Figure [3].

• Checkbox (marker 1). Check for updates at startup. If this box is unchecked,
you can always check for update by typing Ctrl +; or by the menu Help→Check
update.

• (Marker 2) Selecting the language interface by a popup menu:

– Auto: Selecting the language interface with a menu: Selects the language
of the interface depending on the system language system if it is in English,
French or German.

– English:The interface will be in English (regardless of the system language).

– French:The interface will be in French (regardless of the system language).

– German:The interface will be in German (regardless of the system language).

Finally, we can select the type of post treatment (in blue rectangle):

• Automatic backup: every capture is saved directly in a folder with a name con-
taining the date and time. The backup file is shown (marker 3). You can choose
the folder with the button indicated by the marker 4.
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Figure 3: The Preferences dialog

• Manual backup: the user can choose the name and location of the backup capture.

• Clipboard: capture is placed in the clipboard.

• Add annotation: capture is placed in the window for editing annotations.

5 Capture.

5.1 Set the capture rectangle.

At the beginning of the program (see Figure [2]), click on the button Fix the frame.. We
then see the capture window appears (see Figure [4]). Parameters specify the capture
rectangle (shown on the screen by a cyan rectangle with two corners (red square in the
figure):

• Top: vertical position in pixels of the top left corner of the rectangle to capture.

• Left: horizontal pixel position of the top left corner of the rectangle to capture.

• Height: height in pixels of the capture rectangle.

• Width: width in pixels of the capture rectangle.

Two buttons complete these definitions:

• Button Full Screen: the capture rectangle extends to the entire screen. Button
becomes Reset to easily return to the previous value.

• Button Height = Width: lthe capture rectangle becomes a square.

In addition it is possible to change the size (Size Points), color (Color points) and
form (the checkbox Circle→Square) of corners of the capture rectangle.) .

The capture settings allow to fix the dimensions and the position of the rectangle
capture accurately. But it is also possible to set more intuitively practicing drag and
drop on the corners of the capture rectangle. Note that pressing the Option key
during a drag-drop on the corners, will move all the capture rectangle keeping its height
and width.
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Figure 4: Capture window

5.2 Making the capture.

To cancel the capture press Cancel, you return to the Welcome dialog (Figure [2]). To
perform the capture, press the Click: the program continues after the post-treatment
selected in the preferences (see [4]).

6 Annotate an image.

You reach this treatment by clicking on the corresponding button in the Welcome dialog
(see Figure [2]) or by using the menu File→Open an image of the editing window (Ctrl
+ O). Once the image in memory, you can make the annotation in the editor window.

7 Change a metafile.

You reach this treatment by clicking on the corresponding button in the Welcome dialog
(see Figure [2]) or by using the menu File→Open a metafile of the editing window
(Ctrl +Shift + O). Once the image in memory, you can make the annotation in the
editor window.

8 Annotations.

The Tools Menu allows you to create annotations and manipulate your drawing with
the features offered by this menu.
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Figure 5: Tools Menu

8.0.1 Tools→Layers management(Ctrl+L).

It is sometimes useful to group annotations in layers, each layer being visible or not.
Figure [6] gives an example of using layers: in the example shown we have a layer for each
language and a layer for images common to all languages.

Figure 6: Management layers. Column V determines the visibility of a layer. The +
button add a layer, the - button deletes the selected layer. The red arrows allows to
change the imaging order (i.e. the Picture layer will be painted over the German
layer,...). This dialog give you also the choice of the active layer (.i.e. the layer where
you may create your annotations).

8.0.2 Tools→Crop image (Ctrl+R).

It is possible to crop the image. Cropping is defined manually by drag and drop of the
crop rectangle corners. Pressing the Shift key contains the rectangle to becomes a square.

Once the rectangle is adjusted, right click the image to access the contextual menu to
finish or abandon the crop.
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Figure 7: Cropping an image

Figure 8: Contextual menu to finish the cropping

8.0.3 Tools→Framing (Ctrl+F).

With the dialogue Adding a frame (see Figure [9]) you can choose the width and color
of the frame that will surround your image (the position of annotations are preserved
relative to the image).

Figure 9: Adding a frame

8.0.4 Tools→Fit to window (Ctrl+W).

Adjusts the size of the background image to that of the window (the position of the
annotations are preserved relative to the image).
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8.0.5 Tools→Zoom+/- (Ctrl+G)

Enlarged or reduced image background (The position of the annotations iare preserved
relative to the image).

8.0.6 Tools→Flip horizontal (Ctrl+Shift+H).

Performs a horizontal flip of the background image. (The position of annotations iare
preserved relative to the image).

8.0.7 Tools→Flip vertical (Ctrl+Shift+V).

Performs vertical flipping of the image background (the position of annotations are pre-
served relative to the image).

8.0.8 Tools→Rotates left (Ctrl+Shift+L).

Rotates left of the background image (position and orientation annotations are preserved
relative to the image).

8.0.9 Tools→Rotates right(Ctrl+Shift+R).

Rotates right of the background image (position and orientation annotations are preserved
relative to the image).

8.0.10 Tools→Create a text annotation (Ctrl+T).

You can access this function, either by the menu Tools→Create a text annotation
(shortcut (Ctrl + T)) or by the contextual menu [10] (right click in the image).

Figure 10: Contextual menu to create an annotation.

The creation or modification of a text annotation is illustrated Figure [11]. Area (a)
is a prévisalisation your annotation text. Area (b) is where you type your text area and
area (c) gives you the real picture of your annotation. In the dialog box in Figure [11],
there are several areas:

The areas in red are the parameters of the text:

• Justification: left, center, right and justified.

• The choice of font.

• Attributes bold / underlined, italic, and font color.

• Characters size.

Note that in the area (e) one can adjust the vertical position of the text in the
cartridge (Vertical offset).

The blue area define parameters of the cartridge surrounding the annotation:
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• Rectangle, rounded rectangle, ellipse or no cartridge.

• You can also define a margin around the text and a net surrounding the annotation.

The green area define pointers annotation:

• The pointer ends with an arrow.

• It has two pointers ending with an arrow.

• The pointer ends with a square.

• There are two pointers ending with a square.

• No pointer.

• Finally you can:

– Adjusting the thickness of the pointers.

The orange area define colors:

• The background of the cartridge..

• Net decoration.

• Pointers.

Important Note: If when selecting the background color of the cartridge you click
Cancel instead of OK, the bottom of the cartridge is then defined as transparent. Only
the net decoration will be visible. This allows to define geometric figures such as
rectangles (ie squares), rounded rectangles, ellipses (ie circles) playing with the width and
height of the annotation characters (the text remains invisible).

The width of annotation is determined by the sliding bar (area (d)).
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Figure 11: Adding or editing a text annotation.

8.0.11 Tools→Create a picture annotation (Ctrl+P).

The creation or modification of an image annotation is illustrated in figure [12]. Zone
(b) gives you the real picture of your annotation. Your choice of image annotation is
done by clicking on the button (c). In the dialog box in Figure [12], there are several
areas.

The areas in red are the parameters surrounding the cartridge annotation:

• Rectangle, rounded rectangle, ellipse or no cartridge.

• You can also define a margin around the text and a net surrounding the annotation.

The green area define pointers annotation:

• The pointer ends with an arrow.

• It has two pointers ending with an arrow.

• The pointer ends with a square.

• There are two pointers ending with a square.

• No pointer.

• Finally you can:

– Adjusting the thickness of the pointers.

The orange area define the colors:

• The background of the cartridge..
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• Net decoration.

• Pointers.

The width of annotation is determined by the sliding bar (area (d)).

Figure 12: Adding or editing a picture annotation.

9 Selecting an annotation to edit, move, paste, etc

...

Figure 13: The contextual menu to edit an annotation.

To access the context menu of the figure [13], it is necessary to select an annotation.
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Figure 14: The annotation not locked is framed by a red rectangle when the mouse
pointer hovers over the annotation (A). When the mouse is in the center of the annotation
on red square appears. When the mouse is in the center of the annotation, a red square
appears (B). The annotation is then selected.. If the annotation is locked, it is framed
by a cyan rectangle when the mouse pointer hovers over the annotation (C). When the
mouse is in the center of the annotation, a black square appears (D). The annotation
is then selected.

The ends of the pointers can also be selected by the mouseover. Note that the ends
of a pointer, when selected are marked with a yellow circle.

Tip: Two annotations can overlap and the selection of one of them can be difficult. You
can lock the selections and press the Shift key while moving the mouse, the annotation
unlocked will be selected.

When an annotation is selected, you can right click to access the context menu of the
figure [13]which tells you the name of the active layer. You can then:

• Paste the annotation is in the clipboard.

• Delete the selected annotation.

• Change the selected annotation.

• Center horizontally the selected annotation.

• Center vertically the selected annotation.

• Cut the selected annotation and put it in the clipboard.

• Move the selected annotation: a dialog allows you to set the horizontal and vertical
position of the center of the annotation.

• Rotating the annotation around its center of 90 degrees to the left.

• Rotating the annotation around its center of 90 degrees to the right.

• Copy to clipboard annotation.
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• Lock/unlock the annotation.

Tip: When annotation is selected you can move it by drag and drop. The drag and
drop can also be used to move the ends of selected pointers.

Note: Finally, you can move a unlocked selected annotation with the arrow keys
(←,→, ↑, ↓). Displacements are 1 pixel per hit or 10 pixels per hit if you press the
Shift key.

10 Printing and saving your work.

When you edit an annotation, the File menu has the appearance of the figure [15]. Note
that if you have already saved one or more metafiles, you can quickly access the sub-menus
of Open a recent file.

Figure 15: File menu.

10.0.12 Printing.

As shown in Figure [15], before printing, you can define the layout by the Printer options.

10.0.13 Backup.

Figure 16: The warning dialog before exiting the program or load a new image or a new
metafile..

As shown in Figure [15], you can open or save an image or a metafile. You can also
return to the capture [5.2] The dialog in Figure [16] allows you to avoid forgetting
saving your changes.
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11 List of shortcuts.

• Ctrl + O Open a background image.

• Ctrl + Shift + O Open a metafile.

• Ctrl + S Save Image As ...

• Ctrl + Shift + S Save a metafile as ....

• Ctrl + Shift + Q Back to the capture.

• Ctrl + I print the annotated image.

• Ctrl + T Create a text annotation.

• Ctrl + P Creating a picture annotation.

• Ctrl + F Framing the background image.

• Ctrl + R Crop the image.

• Ctrl + W Force the image to fit the window.

• Ctrl + G Zoom increase or decrease the image size.

• Ctrl + Shift + H Flip the image horizontally.

• Ctrl + Shift + V Flip the image vertically.

• Ctrl + Shift + L to left Rotate image.

• Ctrl + Shift + R Rotate right of the image.

• Ctrl + L Management annotation layers.

• Ctrl + , access preferences.

• Ctrl +: Accessing the About dialog ...

• Ctrl +; Checking for updates.

• F1 to access help (this file).
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